Reputation: 11336
Is there a better way to declare this?
if current_user.received_replies.unread.count > 0
What I'm trying to do is match condition only if there's at least one unread
object.
Upvotes: 2
Views: 3452
Reputation: 160551
I'd use:
if current_user.received_replies.unread.any?
From the docs:
= Array.any? (from ruby core) === Implementation from Enumerable ------------------------------------------------------------------------------ enum.any? [{|obj| block } ] -> true or false ------------------------------------------------------------------------------ Passes each element of the collection to the given block. The method returns true if the block ever returns a value other than false or nil. If the block is not given, Ruby adds an implicit block of {|obj| obj} (that is any? will return true if at least one of the collection members is not false or nil. %w{ant bear cat}.any? {|word| word.length >= 3} #=> true %w{ant bear cat}.any? {|word| word.length >= 4} #=> true [ nil, true, 99 ].any? #=> true
Upvotes: 3
Reputation: 3826
This could be a little bit better :
unless current_user.received_replies.unread.empty?
Upvotes: 1
Reputation: 95288
unless current_user.received_replies.unread.empty?
# ...
end
Or, if your if
has an else
, switch the cases (because unless/else
is fugly as hell):
if current_user.received_replies.unread.empty?
# ...
else
# ...
end
Upvotes: 4