markdigi
markdigi

Reputation: 1292

IF Statement multiple conditions, same statement

Hey all, looking to reduce the code on my c# if statements as there are several repeating factors and was wondering if a trimmer solution is possible.

I currently have 2 if statements that need to carry out an identical statement, however the only variable is an extra condition on an if statement when a checkbox is not checked. Im just wondering if there is a way to make it one statement or make the condition string variable, heres the compressed version of the code:

if (checkbox.checked)
  {
    if (columnname != a && columnname != b && columnname != c)
    {
      "statement 1"
    }
  }
else
  {
    if (columnname != a && columnname != b && columnname != c 
        && columnname != A2)
    {
      "statement 1"
    }
  }

Its like I need to run an if statement within the conditions of an if statement if that makes sense, like this psuedo form:

if (columnname != a 
    && columnname != b 
    && columnname != c 
    && if(checkbox.checked{columnname != A2})

Upvotes: 26

Views: 406984

Answers (12)

Noah Everly
Noah Everly

Reputation: 51

Like @sal said, C# 9.0 added improved pattern matching. You can now use is with and and or.

With this, the code:

if (checkbox.checked)
  {
    if (columnname != a && columnname != b && columnname != c)
    {
      "statement 1"
    }
  }
else
  {
    if (columnname != a && columnname != b && columnname != c 
        && columnname != A2)
    {
      "statement 1"
    }
  }

Can be reduced to:

if (checkbox.checked)
  {
    if (columnname is (!= a and != b and != c)
    {
      "statement 1"
    }
  }
else
  {
    if (columnname is (!= a and != b and != c and != A2)
    {
      "statement 1"
    }
  }

This pattern matching also added cleaning up switch statements in a similar way. Definitely worth using.

Upvotes: 3

shaair
shaair

Reputation: 985

It's too late but worth the information

C#9 : you can write

if (columnname is not a or b or c)

Upvotes: 2

Sturm
Sturm

Reputation: 4125

Check this for a more clustered way of checking conditions:

private bool IsColumn(string col, params string[] names) => names.Any(n => n == col);

usage:

private void CheckColumn()
{
     if(!IsColumn(ColName, "Column A", "Column B", "Column C"))
    {
     //not A B C column
    }

}

Upvotes: 8

Daniel Elliott
Daniel Elliott

Reputation: 22857

Use the && (and) operator in combination with the || (or) operator in a nested condition as so:

if (columnname != a 
  && columnname != b 
  && columnname != c
  && (checkbox.checked || columnname != A2))
{
   "statement 1"
}

Should do the trick.

Upvotes: 53

BLong
BLong

Reputation: 69

How about maybe something like this?

    var condCheck1 = new string[]{"a","b","c"};
    var condCheck2 = new string[]{"a","b","c","A2"}

    if(!condCheck1.Contains(columnName) && !checkbox.checked)
        //statement 1
    else if (!condCheck2.Contains(columnName))
        //statment 2

Upvotes: 2

Dan
Dan

Reputation: 1

var test = new char[] {a, b, c}.Contains(columnname));

if(test)
{
  "true statement"
}
else
{
   "false statement"
}

Upvotes: -1

markh44
markh44

Reputation: 6080

I always try to factor out complex boolean expressions into meaningful variables (you could probably think of better names based on what these columns are used for):

bool notColumnsABC = (columnname != a && columnname != b && columnname != c);
bool notColumnA2OrBoxIsChecked = ( columnname != A2 || checkbox.checked );

if (   notColumnsABC 
    && notColumnA2OrBoxIsChecked )
  {
      "statement 1"
  }

Upvotes: 12

mikefrey
mikefrey

Reputation: 4681

if (columnname != a && columnname != b && columnname != c 
        && (columnname != A2 || checkbox.checked))
    {
      "statement 1"
    }

Upvotes: 12

Jason Jackson
Jason Jackson

Reputation: 17260

I think agileguy has the correct answer, but I would like to add that for more difficult situations there are a couple of strategies I take to solve the problem. The first is to use a truth table. If you Google "truth table" you will run across some examples related directly to programming and computer science.

Another strategy I take is to use an anonymous function to encapsulate common logic between various conditions. Create it right before the if block, then use it where needed. This seems to create code that is more readable and maintainable.

Upvotes: 0

Meta-Knight
Meta-Knight

Reputation: 17845

You could also do this if you think it's more clear:

if (columnname != a 
  && columnname != b 
  && columnname != c
{
   if (checkbox.checked || columnname != A2)
   {
      "statement 1"
   }
}

Upvotes: 3

JBrooks
JBrooks

Reputation: 10013

Isn't this the same:

if ((checkbox.checked || columnname != A2) && 
        columnname != a && columnname != b && columnname != c)
  {
      "statement 1"
  }

Upvotes: 3

gjutras
gjutras

Reputation: 764

if (checkbox.checked && columnname != a && columnname != b && columnname != c)
    {
      "statement 1"
    }
else if (columnname != a && columnname != b && columnname != c 
        && columnname != A2)
    {
      "statement 1"
    }

is one way to simplify a little.

Upvotes: 0

Related Questions