Reputation: 1241
Given this method, does this represent some egregious stylistic or semantic faux pas:
private double translateSlider(int sliderVal) {
switch (sliderVal) {
case 0:
return 1.0;
case 1:
return .9;
case 2:
return .8;
case 3:
return .7;
case 4:
return .6;
default:
return 1.0;
}
}
It's clearly not in line with the Java tutorials here.
However, It's clear, concise and so far has yielded exactly what I need. Is there a compelling, pragmatic reason to create a local variable, assign a value to it within each case, add a break to each case and return the value at the end of the method?
Upvotes: 77
Views: 194816
Reputation: 516
If it's Java 14+, you may use functional expression of switch like this:
return switch(region) {
case "us-east-1" -> Region.US_EAST_1;
default -> Region.US_EAST_1;
};
Upvotes: 24
Reputation: 10705
Though the question is old enough it still can be referenced nowdays.
Semantically that is exactly what Java 12 introduced (https://openjdk.java.net/jeps/325), thus, exactly in that simple example provided I can't see any problem or cons.
Upvotes: 0
Reputation: 1596
Best case for human logic to computer generated bytecode would be to utilize code like the following:
private double translateSlider(int sliderVal) {
float retval = 1.0;
switch (sliderVal) {
case 1: retval = 0.9; break;
case 2: retval = 0.8; break;
case 3: retval = 0.7; break;
case 4: retval = 0.6; break;
case 0:
default: break;
}
return retval;
}
Thus eliminating multiple exits from the method and utilizing the language logically. (ie while sliderVal is an integer range of 1-4 change float value else if sliderVal is 0 and all other values, retval stays the same float value of 1.0)
However something like this with each integer value of sliderVal being (n-(n/10))
one really could just do a lambda and get a faster results:
private double translateSlider = (int sliderVal) -> (1.0-(siderVal/10));
Edit:
A modulus of 4 may be in order to keep logic (ie (n-(n/10))%4)
)
Upvotes: 2
Reputation: 28767
From human intelligence view your code is fine. From static code analysis tools view there are multiple returns, which makes it harder to debug. e.g you cannot set one and only breakpoint immediately before return.
Further you would not hard code the 4 slider steps in an professional app. Either calculate the values by using max - min, etc., or look them up in an array:
public static final double[] SLIDER_VALUES = {1.0, 0.9, 0.8, 0.7, 0.6};
public static final double SLIDER_DEFAULT = 1.0;
private double translateSlider(int sliderValue) {
double result = SLIDER_DEFAULT;
if (sliderValue >= 0 && sliderValue < SLIDER_VALUES.length) {
ret = SLIDER_VALUES[sliderValue];
}
return result;
}
Upvotes: 6
Reputation: 73
I think that what you have written is perfectly fine. I also don't see any readability issue with having multiple return statements.
I would always prefer to return from the point in the code when I know to return and this will avoid running logic below the return.
There can be an argument for having a single return point for debugging and logging. But, in your code, there is no issue of debugging and logging if we use it. It is very simple and readable the way you wrote.
Upvotes: 3
Reputation: 9741
Assigning a value to a local variable and then returning that at the end is considered a good practice. Methods having multiple exits are harder to debug and can be difficult to read.
That said, thats the only plus point left to this paradigm. It was originated when only low-level procedural languages were around. And it made much more sense at that time.
While we are on the topic you must check this out. Its an interesting read.
Upvotes: 89
Reputation: 1028
Why not just
private double translateSlider(int sliderval) {
if(sliderval > 4 || sliderval < 0)
return 1.0d;
return (1.0d - ((double)sliderval/10.0d));
}
Or similar?
Upvotes: 0
Reputation: 226
Yes this is good. Tutorials are not always consize and neat. Not only that, creating local variables is waste of space and inefficient
Upvotes: -2
Reputation: 28
If you're going to have a method that just runs the switch and then returns some value, then sure this way works. But if you want a switch with other stuff in a method then you can't use return or the rest of the code inside the method will not execute. Notice in the tutorial how it has a print after the code? Yours would not be able to do this.
Upvotes: 0
Reputation: 11006
I suggest you not use literals.
Other than that the style itself looks fine.
Upvotes: 0
Reputation: 43401
Nope, what you have is fine. You could also do this as a formula (sliderVal < 5 ? (1.0 - 0.1 * sliderVal) : 1.0
) or use a Map<Integer,Double>
, but what you have is fine.
Upvotes: 0