Arun Iphone
Arun Iphone

Reputation: 93

Warning-used as the name of the previous parameter rather than as part of the selector

I am using a function in a class as below

- (void) uploadMorePic:(NSDictionary *) MuliPics: (NSData *)file  

It shows the warning - MuliPics used as the name of the previous parameter rather than as part of the selector

Why that comes ?

Screenshot for example

Upvotes: 8

Views: 10324

Answers (3)

Artisan
Artisan

Reputation: 85

@dpassage 's answer is nice。

The function name of objective-c is not like C or C++, it has some parameter and the same num of description of parameter name。 In your case, you did not set your first parameter name or you did not set your description of your second parameter name.

What @dpassage said was the first condition, missing first parameter name.

Upvotes: 0

dpassage
dpassage

Reputation: 5453

It's a poor message, but it's because you didn't provide a name for the first parameter to your method. Try this:

-(void)uploadMorePic:(NSDictionary *)dict muliPics:(NSData *)file

I also fixed a style issue; the name of the second part of the method name should start with a lower-case letter. I don't know what your method does, so you may be able to come up with a better name.

Upvotes: 15

Wain
Wain

Reputation: 119031

Because you haven't separately specified the parameter name and the selector definition. Basically, you're missing a space and/or a word. Try:

-(void)uploadMorePictures:(NSDictionary *)pics withFile:(NSData *)file

Which separately names and specifies both parameters to the method.

Upvotes: 5

Related Questions