Marc Stober
Marc Stober

Reputation: 10517

jQuery plugin naming convention (for the function)

Which casing looks better to you for a jQuery plugin:

$("#foo").runMyPlugin();

or

$("#foo").runmyplugin();

Is there a naming convention for jQuery that prefers on over the other?

Thanks in advance!

Upvotes: 6

Views: 2414

Answers (1)

Christian C. Salvadó
Christian C. Salvadó

Reputation: 827256

I would recommend you the first one, that convention is widely used in JavaScript, even in the core language by itself, the ECMA Specification uses it, e.g.

Array.prototype.toLocaleString
Object.prototype.hasOwnProperty
Object.prototype.propertyIsEnumerable
// etc...

All identifiers are named with camelCase, and only constructor functions are named with the first letter as capital (PascalCase).

Upvotes: 7

Related Questions