Reputation: 9059
As an special case of List.of(...) or Collections.unmodifiableList() - what is the preferred Java 9 way of pointing to an empty and immutable list?
Keep writing
Collections.emptyList();
or switch to
List.of();
Upvotes: 93
Views: 43685
Reputation: 315
As of JDK 11, If you look at the source code, you see that List.of()
, uses a one-time initialized empty list, similar to Collections.emptyList()
. So, I'll prefer to use List.of()
because:
List.of(E... elements)
(And you should) for non-empty lists, you can use List.of()
for empty ones and enjoy a unified look and feel and get rid of most of the factory methods in Collections API.Upvotes: 15
Reputation: 672
emptyList()
creates a new empty list instance only onceList.of()
is shorten than Collections.emptyList()
but you can use a static import like import static java.util.Collections.emptyList;
and then write only emptyList()
Upvotes: 4
Reputation: 13407
What is the preferred Java 9 way of pointing to an empty and immutable list?
The difference is rather subtle so "preferred" depends on what you want to achieve. Some behavioral differences:
List.of
will throw an exception on contains(null)
invocations.emptyList()
on JDK 8 and previous, but not List.of
.In terms or conveying that you want an empty list, emptyList()
might look better, but this is just a temporary convention. If developers start using List.of()
(which is much shorter than Collections.emptyList()
) then it will become a known and accepted way, it's just new. If you think about it, there are some constructs we use which do not always convey what they do by themselves, but we got accustomed to them.
So there is no strictly preferred way. If the behavior does not matter use whatever you want.
Upvotes: 45
Reputation: 77177
Collections.emptyList()
does not need to create a new object for each call; it's typical, as in OpenJDK, to just return the singleton EMPTY_LIST
object. Additionally, it's clearer that you intend to mean an empty list rather than having forgotten to fill in a placeholder.
Use emptyList()
; it's both faster (up to Java target level 1.9) and more readable.
Upvotes: 60