Reputation: 1823
when passing extras such as Intent.putExtra("myName", myName), what's the convention for the name of the extra?
ie: if passing data between two activities, both would put/extract data under the id "myName", but should I just hardcode "myName" everywhere, or keep the value in the R.values.string?
Upvotes: 29
Views: 8935
Reputation: 13564
Hardcoding is definitely not an ideal solution.
The convention used in the Android framework is to create public static final
constants named EXTRA_FOO
(where FOO is the name of your key) like Intent.EXTRA_ALARM_COUNT
The actual value of the constant is a name spaced string to avoid conflicts: "android.intent.extra.ALARM_COUNT"
If you don't want to create dependencies between your Activities with constants, then you should consider putting these keys into string values within your strings.xml file. I tend to follow the same naming convention when defining the keys in xml:
<string name="EXTRA_MY_NAME">com.me.extra.MY_NAME</string>
It still reads like a static constant from the Java side:
getString(R.string.EXTRA_MY_NAME);
Upvotes: 47
Reputation: 28418
The only thing I saw in documentation is that extra keys should start from package name. However I do not fully follow this and the app works Ok so far.
I would prefer to use R.string.some_key within the code just to have it clean and dry.
Upvotes: 0